2017年12月21日木曜日

windows10起動時にRadeonSettings.exeのエラーが表示される

 windows10起動時に、radeon settings.exeのアプリケーションエラーがよく表示されるようになった。fall creators update以降出るようになったんですが、windows10は、いつになったら安定するんですかね。


信頼性モニターにエラー表示
 信頼性モニターのほうにも、「radeon settings:host application 動作が停止しました」と何度も表示される。ほんとうるさい。


windows updateデータベースにエラー
 windows updateのトラブルシューティングをやってみると、「window updateデータベースにエラーが発生した可能性があります」、「windows updateコンポーネントを修復する必要があります」とトラブルシューティングやるたびに発生する。


グラフィックドライバの更新
 グラフィックドライバをクリーンインストールしても、更新直後はエラー表示が出ることはないが、しばらく経つとまたエラー表示が出る。

 バージョンを色々変えてみたが、全く効果なし。

sfc /scannowをやってみる
 スタートメニューをクリックして、windowsシステムツール>コマンドプロンプトを右クリックして、その他>管理者として実行をクリックします。sfc /scannowを入力し、enterキーを押します。


 これも効果なし。

DISM /Online /Cleanup-image /Restorehealthをやってみる
 sfc /scannowの時と同様に、コマンドプロンプトを管理者として実行して、dism /online /cleanup-image /restorehealthを入力して、enterキーを押します。特に問題なく終わったが、効果はなし。


互換性モードでアプリケーションを起動する
 ローカルディスク(C)>Program Files>AMD>CNext>CNextで、RadeonSettings.exeを右クリックして、プロパティをクリックします。

 互換性のタブで、「互換性トラブルシューティングツールの実行」をクリックします。


 「推奨設定を使用する」をクリックします。


 「プログラムのテスト」をクリックして、radeon設定が表示されるかを確認します。表示されるのを確認したら、「次へ」をクリックします。


 「はい、このプログラムのこの設定を保存します」をクリックします。


 「閉じる」をクリックします。


 「すべてのユーザーの設定を変更」をクリックします。


 互換モードで、互換モードでプログラムを実行するにチェックを入れて、windows8を選択します。


 適用をクリックして、OKをクリックします。

再びエラー表示
 2、3日は出なかったのですが、また出ました。OSをクリーンインストールしようかと思ったのですが、ドライバをもう一度クリーンインストールしてみました。

 普段は、コントロールパネルからドライバを削除した後、再起動して、セーフモードに入り、DDUで残りを削除するのですが、今回は更にCドライブにあるAMDのフォルダ全部削除してから、ドライバをインストールしました。

 そもそもグラフィックドライバしかインストールしていなかった。ryzen masterはアンインストールしてあるし、chipset ドライバは、最初のころインストールしていたんですが、電源オプションを、ryzen blancedから高パフォーマンスに変更したので、必要性を感じなかった。

 それに、いろいろなバージョンのグラフィックドライバをインストールしたりアンインストールしたりしてたのでめんどくさくなってインストールしてなかった。

 インストールしていなくても、デバイスマネージャーではてなマークは出なかったのでおそらく問題はなかったと思う。

またエラー表示
 上の0xc0000142は、セキュリティソフトにも関係があるらしい。今、aviraを使用しているのですが、これを変更する前に、ちょっと気になっていることがあります。

 CCleanerを起動するたびに、ユーザーアカウント制御が出ます。なので、まずアンインストールしてからインストールし直しました。

 これで、windows updateデータベースにエラーは出なくなりました。

またまたエラー表示
 もうしょうがないので、グラフィックドライバをradeon crimson relive17.11.1からradeon crimson relive17.12.1に、セキュリティソフトをaviraからavastに変更しました。

 しばらく経ちましたがエラーは発生してません。どうやら、aviraが原因だったようです。検索してみると他にも不具合があるようです。そっちの不具合は自分の環境では発生しませんでしたが。どうも、aviraはfall creators updateと相性が悪いようです。