2018年4月26日木曜日

youtubeで動画を再生するとブツブツ音がする

 linuxへ移行したのはいいのですが、haswellのlinuxmint18.3をインストールしたパソコンでyoutubeの動画を再生するとブツブツ音がするようになった。

 windows10の時にはこんなことは起こらなかったので、原因を探ってみた。

原因?
 原因の一つとしては、OSやサウンドドライバが原因と考えられる。

 OSに関しては、windowsに戻すわけにはいかないので、linuxしかないんですが、もうすぐubuntu18.04が出るのでubuntuをベースにしたlinuxもバージョンアップするので変更するのはそれからですね。

 いろいろ調べてみると、linuxのpulseaudioの評判があまりよろしくない。

 sandybridgeにインストールしたpeppermint8ではpulseaudioですが問題なくyoutubeは再生できてブツブツ音がすることはありません。

 pulseaudioが原因ではなさそう。

 ブラウザは、haswell、sandybridgeのPC共に同じバージョンのfirefoxなのだが....

linuxmint18.3からpeppermint8に変更
 もうすぐlinuxのバージョンアップがあるので待とうかと思ったのですがやっぱりそれまで待っていられないので、haswellのパソコンのOSをlinuxmint18.3からpeppermint8に変えてみたが変わらず、やはりyoutubeを再生するとブツブツ音がする。

 ちょっと気になることがある。

音量調整がおかしい
 音量調節が微妙にずれている。


 100%にしても、ブラウザを再起動またはループ再生するとまた88%とか90%になってしまう。

 これはfirefoxの場合。

 原因は何でしょうね。さっぱりわからん。

 flashが原因かもしれないとネットにあったが、無効にしても変化なし。

chromiumに変更
 chromiumブラウザーでも試してみましたが、やっぱりブツブツ音がする。

 設定を色々変えてみたが変化なし。

 CPUがcore i5 4670kでメモリが16GBなのでスペック不足は考えられないし、う~ん。

 試しにヘッドホーンで聞いてみると、ブツブツ音することはない。

 となると、オーディオケーブルあるいはスピーカーの故障なのか?

 windows10の時は問題なかったのですが...

オーディオケーブルを変更
 変化なし。無駄な買い物でしたね。

 残るはスピーカーだが、テレビをモニターにしているのですが、テレビを視聴している時はブツブツ音は出てないのでさっぱり原因がわからず。

HTML5が原因か
 HTML5が原因かもというのを見つけて、HTML5を無効化するアドオンを入れてみたが、何も変わらず変化なし。

グラフィックボードが原因か
 グラボが原因かもと思って取り去ってみたが、効果なし。解像度がおかしくなってしまう新たな問題も発生。解像度のほうの問題もいろいろ調べてやってみたけど、効果なしなのでグラボ戻すしかない状態。

HPETを無効化
 HPET(high precision event timers)を有効にしていると一部のlinuxで不具合があるらしいとの記事を見つけたので早速やってみたが、効果なし。

メモリのテスト
 memtestも一応やってみたけど、問題なし。

 なんかここまでくると、脆弱性対策のmicrocodeが原因じゃないかと思える。haswellのみ。sandybridgeは問題なし。

 普通ならmicrocodeが原因かもしれないなんて疑いもしないのですが、脆弱性対策のintelの対応を見ていると可能性の一つとして考えざるを得ませんね。

 まあ、マザーボードの故障もあり得ますが...